User login

Who's new

  • Alicia22
  • hassinger
  • qutrytty
  • ets11taran
  • suryapackers1

Config Bug

February 09, 2009 - 22:06pm

I have noticed that no matter what I try, the config isnt saving what i change in game. Do I need to manually edit the config file or is there a way to make it save changes in the game?

February 27, 2009 - 07:57am

WADUP GIBZ!@!! This is DeNL82 from heat.net(heat users never used to add ".net" to heat back n the day, remember?)

Anyways, if you do not remember this, this is the guy who had held a grudge on you for yearzzzzz ever since you ownt me like 50 points to -20 points on edge, wayy back in the day, by JUST USING SHOT GUN!!

I STILL REMEMBER THAT GAME YO.

Anyways, how you doing Gibz, nice to still see you(and us, in general) around, aye?<3

***edit******* And what's up with the 1970 bit? LOLOLOLOLOLOL!

February 10, 2009 - 00:06am

That shouldn't be the case. What platform are you on, and what settings in particular do not seem to be saving? As long as the game exits normally (read: doesn't crash), most console variables are flushed to your config. On Unix variants, this is ~/.quake2world/default/quake2world.cfg. On Windows, I think it's C:\My Documents\My Games\Quake2World\default\quake2world.cfg. But there should be little reason to edit the file.

February 10, 2009 - 15:39pm

basically this was a wide array of commands, none of which stuck for me, here are some of the basic ones that wouldnt save, im on windows xp sp2:

name
rate
all cl_ and r_ commands
bind key "function"

February 11, 2009 - 14:48pm

I prefer to edit autoexec.cfg instead of quake2world.cfg. The game doesn't mess with that one so it's easier to keep it well arranged.

February 11, 2009 - 12:59pm

This is kind of a shot in the dark, but you might need to manually create the /my documents/my games/quake2world folder, unless it already exists. If I remember correctly, this is what I had to do when q2w first switched user data over to that folder.

February 26, 2009 - 18:10pm

I just did a test with a nice fresh compile from SVN and a clean configuration: it looks like the problem is the 'My Games' directory. It doesn't get created when it doesn't exist.

March 09, 2009 - 03:29am

In case anyone was following this thread, this has been fixed as of 2/26 (revision 222).

February 11, 2009 - 21:15pm

Ah, good to know TRaK. I've created a ticket in Trac so we can track this one:

http://jdolan.dyndns.org/trac/ticket/117

(I really just wanted to use 3 homonyms for "track" in one post.)

February 27, 2009 - 07:54am

hahahah good one, Sir!